Commit 3df84a5c authored by Daniel Wolf's avatar Daniel Wolf
Browse files

Update dependencies

parent a86027a3
<component name="ProjectCodeStyleConfiguration">
<code_scheme name="Project" version="173">
<DBN-PSQL>
<case-options enabled="false">
<option name="KEYWORD_CASE" value="lower" />
<option name="FUNCTION_CASE" value="lower" />
<option name="PARAMETER_CASE" value="lower" />
<option name="DATATYPE_CASE" value="lower" />
<option name="OBJECT_CASE" value="preserve" />
</case-options>
<formatting-settings enabled="false" />
</DBN-PSQL>
<DBN-SQL>
<case-options enabled="false">
<option name="KEYWORD_CASE" value="lower" />
<option name="FUNCTION_CASE" value="lower" />
<option name="PARAMETER_CASE" value="lower" />
<option name="DATATYPE_CASE" value="lower" />
<option name="OBJECT_CASE" value="preserve" />
</case-options>
<formatting-settings enabled="false">
<option name="STATEMENT_SPACING" value="one_line" />
<option name="CLAUSE_CHOP_DOWN" value="chop_down_if_statement_long" />
<option name="ITERATION_ELEMENTS_WRAPPING" value="chop_down_if_not_single" />
</formatting-settings>
</DBN-SQL>
<JetCodeStyleSettings>
<option name="CODE_STYLE_DEFAULTS" value="KOTLIN_OFFICIAL" />
</JetCodeStyleSettings>
......
......@@ -159,8 +159,8 @@ dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk8:$KOTLIN_VERSION"
implementation('org.jetbrains.kotlinx:kotlinx-coroutines-core:1.5.1')
implementation 'org.jetbrains.kotlinx:kotlinx-coroutines-android:1.5.1'
implementation('org.jetbrains.kotlinx:kotlinx-coroutines-core:1.5.2')
implementation 'org.jetbrains.kotlinx:kotlinx-coroutines-android:1.5.2'
implementation "com.frostnerd.utilskt:lifecycle:$frostnerdLifecycleVersion" // https://git.frostnerd.com/AndroidUtils/lifecyclekt
......@@ -173,12 +173,12 @@ dependencies {
storeImplementation 'com.google.android.gms:play-services-cronet:17.0.1'
fdroidImplementation 'com.google.android.gms:play-services-cronet:17.0.1'
implementation 'androidx.work:work-runtime:2.5.0'
implementation 'androidx.work:work-runtime:2.7.0'
implementation 'androidx.appcompat:appcompat:1.3.1'
implementation "androidx.preference:preference:1.1.1"
implementation "com.google.android.material:material:1.4.0"
implementation 'androidx.localbroadcastmanager:localbroadcastmanager:1.1.0-alpha01'
implementation "androidx.core:core-ktx:1.6.0"
implementation "androidx.core:core-ktx:1.7.0"
implementation "androidx.room:room-runtime:$room_version"
kapt "androidx.room:room-compiler:$room_version"
......@@ -191,12 +191,12 @@ dependencies {
leakCanaryImplementation 'com.squareup.leakcanary:leakcanary-android:2.7'
implementation "com.squareup.okhttp3:okhttp:4.9.1"
implementation 'com.squareup.okhttp3:okhttp-dnsoverhttps:4.9.1'
implementation 'com.github.AppIntro:AppIntro:6.0.0'
implementation "com.squareup.okhttp3:okhttp:4.9.2"
implementation 'com.squareup.okhttp3:okhttp-dnsoverhttps:4.9.2'
implementation 'com.github.AppIntro:AppIntro:6.1.0'
storeImplementation 'com.google.android.play:core:1.10.0'
fdroidImplementation 'com.google.android.play:core:1.10.0'
storeImplementation 'com.google.android.play:core:1.10.2'
fdroidImplementation 'com.google.android.play:core:1.10.2'
}
def getGitCommitHash() {
......
......@@ -33,12 +33,12 @@ ext.nexus_password = getNexusPassword()
buildscript {
ext {
ext.KOTLIN_VERSION = '1.5.21'
ext.KOTLIN_VERSION = '1.5.31'
}
ext.ANDROID_COMPILE_SDK = (System.getenv("ANDROID_COMPILE_SDK") == null ? 30 : System.getenv("ANDROID_COMPILE_SDK")).toInteger()
ext.ANDROID_COMPILE_SDK = (System.getenv("ANDROID_COMPILE_SDK") == null ? 31 : System.getenv("ANDROID_COMPILE_SDK")).toInteger()
ext.ANDROID_TARGET_SDK = (System.getenv("ANDROID_TARGET_SDK") == null ? ANDROID_COMPILE_SDK : System.getenv("ANDROID_TARGET_SDK")).toInteger()
ext.ANDROID_MIN_SDK = (System.getenv("ANDROID_MIN_SDK") == null ? 14 : System.getenv("ANDROID_COMPILE_SDK")).toInteger()
ext.ANDROID_GRADLE_PLUGIN_VERSION = System.getenv("ANDROID_GRADLE_PLUGIN_VERSION") == null ? "7.0.1" : System.getenv("ANDROID_GRADLE_PLUGIN_VERSION")
ext.ANDROID_GRADLE_PLUGIN_VERSION = System.getenv("ANDROID_GRADLE_PLUGIN_VERSION") == null ? "7.0.3" : System.getenv("ANDROID_GRADLE_PLUGIN_VERSION")
println "COMPILE SDK Version: $ANDROID_COMPILE_SDK"
println "TARGET SDK Version: $ANDROID_TARGET_SDK"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment